source: branches/stable/ipdb.spec@ 445

Last change on this file since 445 was 445, checked in by Kris Deugau, 14 years ago

/branches/stable

Bring /branches/stable up to date with /trunk. See #13.

  • Property svn:keywords set to Id
File size: 1.9 KB
Line 
1# spec file for IPDB
2# $Id: ipdb.spec 445 2010-07-26 21:00:00Z kdeugau $
3
4%define errata 99
5
6# A collection of magic to set the release "number" such that dist upgrades will, erm, upgrade.
7%if %{?debdist:0}%{?!debdist:1}
8%define debdist etch
9%endif
10%if "%{debdist}" == "sarge"
11%define errata 0
12%endif
13%if "%{debdist}" == "dapper"
14%define errata 1
15%endif
16%if "%{debdist}" == "etch"
17%define errata 2
18%endif
19%if "%{debdist}" == "lenny"
20%define errata 3
21%endif
22%if "%{debdist}" == "squeeze"
23%define errata 4
24%endif
25%if %{?relnum:0}%{?!relnum:1}
26%define relnum 1
27%endif
28
29%define release %{relnum}.%{errata}%{debdist}
30
31Summary: IP Database
32Name: ipdb
33Version: #VERSION#
34Release: %{release}
35Group: Applications/System
36Source: ipdb-#VERSION#.tar.gz
37Packager: Kris Deugau <kdeugau@deepnet.cx>
38BuildRoot: /var/tmp/%{name}-%{version}
39License: GPL 3+
40BuildArch: noarch
41Requires: perl(NetAddr::IP) >= 4, perl(DBD:Pg)
42%if %{_vendor} == "debbuild"
43Recommends: perl(Sys::SigAction)
44%endif
45
46%description
47A web-based IP address allocation management tool
48
49%prep
50%setup
51
52%build
53
54%install
55# le sigh. rpm's makeinstall macro includes the buildroot in the dirs, so it will break here. :/
56make \
57 prefix=%{_prefix} \
58 exec_prefix=%{_exec_prefix} \
59 bindir=%{_bindir} \
60 sbindir=%{_sbindir} \
61 sysconfdir=%{_sysconfdir} \
62 datadir=%{_datadir} \
63 includedir=%{_includedir} \
64 libdir=%{_libdir} \
65 libexecdir=%{_libexecdir} \
66 localstatedir=%{_localstatedir} \
67 sharedstatedir=%{_sharedstatedir} \
68 mandir=%{_mandir} \
69 infodir=%{_infodir} \
70 install DESTDIR=$RPM_BUILD_ROOT
71
72%clean
73if [ "$RPM_BUILD_ROOT" != "/" ]; then
74 rm -rf $RPM_BUILD_ROOT
75fi
76
77%files
78%{_libdir}/ipdb
79%attr(-,-,0755) %{_libdir}/ipdb/cgi-bin/*.cgi
80%attr(-,-,0755) %{_libdir}/ipdb/cgi-bin/*.pl
81%attr(-,-,0755) %{_libdir}/ipdb/cgi-bin/extras/*.pl
82%config %{_sysconfdir}/ipdb/MyIPDB.pm
83%{_sysconfdir}/ipdb
84
85%changelog
86* Mon Jun 28 2010 Kris Deugau <kdeugau@deepnet.cx> 2.6-1
87- Initial package
Note: See TracBrowser for help on using the repository browser.