1 | # $Id: debbuild.spec 201 2015-08-03 21:36:21Z kdeugau $
|
---|
2 | # Refer to the following for more info on .spec file syntax:
|
---|
3 | # http://www.rpm.org/max-rpm/
|
---|
4 | # http://www.rpm.org/max-rpm-snapshot/ (Updated version of above)
|
---|
5 | # http://docs.fedoraproject.org/drafts/rpm-guide-en/
|
---|
6 | # More links may be available from http://www.rpm.org
|
---|
7 |
|
---|
8 | %define release %{relnum}.%{dist}
|
---|
9 |
|
---|
10 | Summary: Build Debian-compatible .deb packages from RPM .spec files
|
---|
11 | Name: debbuild
|
---|
12 | Version: #VERSION#
|
---|
13 | Release: %{release}
|
---|
14 | Source: https://secure.deepnet.cx/releases/debbuild/debbuild-%{version}.tar.gz
|
---|
15 | Group: Development/Tools
|
---|
16 | License: GPLv2+
|
---|
17 | Packager: Kris Deugau <kdeugau@deepnet.cx>
|
---|
18 | Requires: perl, build-essential, pax, fakeroot, bash
|
---|
19 | %if %{_vendor} == "debbuild"
|
---|
20 | Recommends: patch, bzip2, xz-utils
|
---|
21 | # For setting DEB_HOST_ARCH
|
---|
22 | Recommends: dpkg-architecture
|
---|
23 | Suggests: rpm, subversion
|
---|
24 | %endif
|
---|
25 | BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
---|
26 | BuildArch: noarch
|
---|
27 |
|
---|
28 | %description
|
---|
29 | debbuild attempts to build Debian-friendly semi-native packages from
|
---|
30 | RPM spec files, RPM-friendly tarballs, and RPM source packages
|
---|
31 | (.src.rpm files). It accepts most of the options rpmbuild does, and
|
---|
32 | should be able to interpret most spec files usefully. Perl modules
|
---|
33 | should be handled via CPAN+dh-make-perl instead as it's simpler
|
---|
34 | than even tweaking a .spec template.
|
---|
35 |
|
---|
36 | Note that patch is not strictly required unless you have .spec files
|
---|
37 | with %patch directives, and RPM is not required unless you wish to
|
---|
38 | rebuild .src.rpm source packages as .deb binary packages.
|
---|
39 |
|
---|
40 | %prep
|
---|
41 | # Steps to unpack and patch source as needed
|
---|
42 | %setup -q
|
---|
43 |
|
---|
44 | %build
|
---|
45 | # nothing to do here
|
---|
46 |
|
---|
47 | %install
|
---|
48 | # Steps to install to a temporary location for packaging
|
---|
49 | [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
|
---|
50 | make install DESTDIR=$RPM_BUILD_ROOT
|
---|
51 |
|
---|
52 | # Fill in the pathnames to be packaged here
|
---|
53 | %files
|
---|
54 | %{_bindir}/*
|
---|
55 | %{_mandir}/man8/*
|
---|
56 |
|
---|
57 | %changelog
|
---|
58 | * Sun Jul 19 2015 Kris Deugau <kdeugau@deepnet.cx>
|
---|
59 | - Remove the stack of %if's determining the Debian dist; use the recently
|
---|
60 | refined %{dist} instead
|
---|
61 |
|
---|
62 | * Thu Feb 28 2008 Kris Deugau <kdeugau@deepnet.cx> -1
|
---|
63 | - Initial package
|
---|