source: trunk/debbuild.spec@ 197

Last change on this file since 197 was 197, checked in by kdeugau, 9 years ago

/trunk

Commit update to .spec file removing the stack of %if blocks in favour
of a single %define using the newish %dist

  • Property svn:keywords set to Id
File size: 2.0 KB
Line 
1# $Id: debbuild.spec 197 2015-08-03 21:01:32Z kdeugau $
2# Refer to the following for more info on .spec file syntax:
3# http://www.rpm.org/max-rpm/
4# http://www.rpm.org/max-rpm-snapshot/ (Updated version of above)
5# http://docs.fedoraproject.org/drafts/rpm-guide-en/
6# More links may be available from http://www.rpm.org
7
8%define release %{relnum}.%{dist}
9
10Summary: Build Debian-compatible .deb packages from RPM .spec files
11Name: debbuild
12Version: #VERSION#
13Release: %{release}
14Source: https://secure.deepnet.cx/releases/debbuild/debbuild-%{version}.tar.gz
15Group: Development/Tools
16License: GPLv2+
17Packager: Kris Deugau <kdeugau@deepnet.cx>
18Requires: perl, build-essential, pax, fakeroot, bash
19%if %{_vendor} == "debbuild"
20Recommends: patch, bzip2
21# For setting DEB_HOST_ARCH
22Recommends: dpkg-architecture
23Suggests: rpm, subversion
24%endif
25BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
26BuildArch: noarch
27
28%description
29debbuild attempts to build Debian-friendly semi-native packages from
30RPM spec files, RPM-friendly tarballs, and RPM source packages
31(.src.rpm files). It accepts most of the options rpmbuild does, and
32should be able to interpret most spec files usefully. Perl modules
33should be handled via CPAN+dh-make-perl instead as it's simpler
34than even tweaking a .spec template.
35
36Note that patch is not strictly required unless you have .spec files
37with %patch directives, and RPM is not required unless you wish to
38rebuild .src.rpm source packages as .deb binary packages.
39
40%prep
41# Steps to unpack and patch source as needed
42%setup -q
43
44%build
45# nothing to do here
46
47%install
48# Steps to install to a temporary location for packaging
49[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
50make install DESTDIR=$RPM_BUILD_ROOT
51
52# Fill in the pathnames to be packaged here
53%files
54%{_bindir}/*
55%{_mandir}/man8/*
56
57%changelog
58* Sun Jul 19 2015 Kris Deugau <kdeugau@deepnet.cx>
59- Remove the stack of %if's determining the Debian dist; use the recently
60 refined %{dist} instead
61
62* Thu Feb 28 2008 Kris Deugau <kdeugau@deepnet.cx> -1
63- Initial package
Note: See TracBrowser for help on using the repository browser.