source: trunk/debbuild.spec@ 141

Last change on this file since 141 was 141, checked in by kdeugau, 16 years ago

/trunk

Add .spec file and Makefile to make creating a tarball and package easier.

  • Property svn:keywords set to Id
File size: 2.5 KB
Line 
1# $Id: debbuild.spec 141 2008-02-28 17:50:36Z kdeugau $
2# Refer to the following for more info on .spec file syntax:
3# http://www.rpm.org/max-rpm/
4# http://www.rpm.org/max-rpm-snapshot/ (Updated version of above)
5# http://docs.fedoraproject.org/drafts/rpm-guide-en/
6# More links may be available from http://www.rpm.org
7
8# A collection of magic to set the release "number" such that dist upgrades will, erm, upgrade.
9# NB: This really only applies to packages built with debbuild.
10%if %{?debdist:0}%{?!debdist:1}
11%define debdist etch
12%endif
13%if "%{debdist}" == "sarge"
14%define errata 0
15%endif
16%if "%{debdist}" == "dapper"
17%define errata 1
18%endif
19%if "%{debdist}" == "etch"
20%define errata 2
21%endif
22%if "%{debdist}" == "lenny"
23%define errata 3
24%endif
25%if %{?relnum:0}%{?!relnum:1}
26%define relnum 1
27%endif
28
29# %{_vendor} is only set to "redhat" on Red Hat (Enterprise) Linux and direct
30# derivatives/ancestors (eg Fedora Core). Upstream rpm (as packaged in Debian,
31# for instance) sets it to "rpm". debbuild sets it to "debbuild".
32%if %{_vendor} == "redhat"
33%define errata el4
34%define release %{relnum}.%{errata}
35%else
36%define release %{relnum}.%{errata}%{debdist}
37%endif
38
39Summary: Build Debian-compatible .deb packages from RPM .spec files
40Name: debbuild
41Version: #VERSION#
42Release: %{release}
43Source: http://www.deepnet.cx/debbuild/debbuild-%{version}.tar.gz
44Group: Development/Tools
45License: GPLv2
46Packager: Kris Deugau <kdeugau@deepnet.cx>
47Requires: build-essential, pax, fakeroot
48%if %{_vendor} == "debbuild"
49Recommends: patch
50Suggests: rpm, subversion
51%endif
52BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
53
54%description
55debbuild attempts to build Debian-friendly semi-native packages from
56RPM spec files, RPM-friendly tarballs, and RPM source packages
57(.src.rpm files). It accepts most of the options rpmbuild does, and
58should be able to interpret most spec files usefully. Perl modules
59should be handled via CPAN+dh-make-perl instead as it's simpler
60than even tweaking a .spec template.
61
62Note that patch is not strictly required unless you have .spec files
63with %patch directives, and RPM is not required unless you wish to
64rebuild .src.rpm source packages as .deb binary packages.
65
66%prep
67# Steps to unpack and patch source as needed
68%setup -q
69
70%build
71# Steps to compile the source
72%configure
73make
74
75%install
76# Steps to install to a temporary location for packaging
77[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
78%makeinstall
79
80# Fill in the pathnames to be packaged here
81%files
82%{_bindir}/*
83%{_mandir}/man1/*
84%doc README
85
86%changelog
87* Mon Jan 01 1900 Name <email@site> -relnum
88- Packaging comment
Note: See TracBrowser for help on using the repository browser.