source: trunk/debbuild.spec@ 181

Last change on this file since 181 was 181, checked in by kdeugau, 9 years ago

/trunk

Another miscellaneous update; add Debian jessie to the list in the
internal .spec file

  • Property svn:keywords set to Id
File size: 2.7 KB
Line 
1# $Id: debbuild.spec 181 2015-05-28 01:47:04Z kdeugau $
2# Refer to the following for more info on .spec file syntax:
3# http://www.rpm.org/max-rpm/
4# http://www.rpm.org/max-rpm-snapshot/ (Updated version of above)
5# http://docs.fedoraproject.org/drafts/rpm-guide-en/
6# More links may be available from http://www.rpm.org
7
8# A collection of magic to set the release "number" such that dist upgrades will, erm, upgrade.
9# NB: This really only applies to packages built with debbuild.
10%if %{?debdist:0}%{?!debdist:1}
11%define debdist etch
12%endif
13%if "%{debdist}" == "sarge"
14%define errata 0
15%endif
16%if "%{debdist}" == "dapper"
17%define errata 1
18%endif
19%if "%{debdist}" == "etch"
20%define errata 2
21%endif
22%if "%{debdist}" == "lenny"
23%define errata 3
24%endif
25if "%{debdist}" == "squeeze"
26%define errata 4
27%endif
28if "%{debdist}" == "wheezy"
29%define errata 5
30%endif
31if "%{debdist}" == "jessie"
32%define errata 6
33%endif
34%if %{?relnum:0}%{?!relnum:1}
35%define relnum 1
36%endif
37
38# %{_vendor} is only set to "redhat" on Red Hat (Enterprise) Linux and direct
39# derivatives/ancestors (eg Fedora Core). Upstream rpm (as packaged in Debian,
40# for instance) sets it to "rpm". debbuild sets it to "debbuild".
41%if %{_vendor} == "redhat"
42%define errata el4
43%define release %{relnum}.%{errata}
44%else
45%define release %{relnum}.%{errata}%{debdist}
46%endif
47
48Summary: Build Debian-compatible .deb packages from RPM .spec files
49Name: debbuild
50Version: #VERSION#
51Release: %{release}
52Source: http://www.deepnet.cx/debbuild/debbuild-%{version}.tar.gz
53Group: Development/Tools
54License: GPLv2+
55Packager: Kris Deugau <kdeugau@deepnet.cx>
56Requires: perl, build-essential, pax, fakeroot, bash
57%if %{_vendor} == "debbuild"
58Recommends: patch, bzip2
59Suggests: rpm, subversion
60%endif
61BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
62BuildArch: noarch
63
64%description
65debbuild attempts to build Debian-friendly semi-native packages from
66RPM spec files, RPM-friendly tarballs, and RPM source packages
67(.src.rpm files). It accepts most of the options rpmbuild does, and
68should be able to interpret most spec files usefully. Perl modules
69should be handled via CPAN+dh-make-perl instead as it's simpler
70than even tweaking a .spec template.
71
72Note that patch is not strictly required unless you have .spec files
73with %patch directives, and RPM is not required unless you wish to
74rebuild .src.rpm source packages as .deb binary packages.
75
76%prep
77# Steps to unpack and patch source as needed
78%setup -q
79
80%build
81# nothing to do here
82
83%install
84# Steps to install to a temporary location for packaging
85[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
86make install DESTDIR=$RPM_BUILD_ROOT
87
88# Fill in the pathnames to be packaged here
89%files
90%{_bindir}/*
91%{_mandir}/man8/*
92
93%changelog
94* Thu Feb 28 2008 Kris Deugau <kdeugau@deepnet.cx> -1
95- Initial package
Note: See TracBrowser for help on using the repository browser.